Back to overview
Maintenance

Database Upgrade

May 4, 2026 at 7:00pm UTC  –  May 4, 2026 at 8:09pm UTC
Affected services
uk.secure.clinic

Resolved
May 4, 2026 at 8:09pm UTC

Maintenance ended

Created
May 4, 2026 at 7:00pm UTC

The database upgrade has been completed ahead of time, and the system is returned to normal.