Back to overview
Downtime
System is unvailable
May 01 at 06:58pm BST
Affected services
uk.secure.clinic
Resolved
May 01 at 07:24pm BST
The fix has been implemented and the service is once again available. Please refresh your browsers if you are still experiencing the issue.
Affected services
Created
May 01 at 06:58pm BST
After an unexpected error during routine maintenance, users are unable to log in to the system. Users see the loading screen indefinitely. A fix has been identified and is being implemented as soon as possible.
Affected services