Back to overview
Downtime
UK Secure Clinic Unavailable
Feb 26 at 06:21pm GMT
Affected services
uk.secure.clinic
Resolved
Feb 26 at 06:27pm GMT
The cause the incident has been identified and rolled back successfully. Total downtime 7 minutes.
Affected services
Created
Feb 26 at 06:21pm GMT
During an out of hours update, users are currently unable to access Secure Clinic from the United Kingdom. Changes are currently being rolled back and the total downtime is expected to be less than 15 minutes.
Affected services